Introduction
Articles
Snapshots
Links
Books
Commerce
Outdoors
Me :)

Your comments & suggestions may be mailed to:
archeryring@nm.ru

Copyright ї 1998 Taras Plakhotnichenko
Most recent revision 22 Feb 2004


стрельба из лука в России

The first archery dedicated WEB site in Russia





! Эта информация больше предназнячена для меня самого, если кому-то она окажется
! полезной - буду рад.
!
!Работающая тестовая конфигурация для Cisco uBR7111E - универсальный широкополосный
! маршрутизатор. Коротко говоря, предназначен для передачи данных по телевизионным
! кабельным сетям - стандарт DOCSIS.
! Внешний dhcp сервер, ppp сессии для AUX порта, ssh, rsh управление,
! ip accounting, netflow, профили модуляции, netflow, pppoe.
!
!
version 12.2
service timestamps debug uptime
service timestamps log datetime localtime
service password-encryption
service udp-small-servers max-servers no-limit
!
hostname ubr1
!
boot system flash disk0:ubr7100-ik8s-mz.122-15.BC1b.bin
logging queue-limit 100
enable secret 5 XXXX
enable password 7 XXXXX
!
username admin password 7 XXXXX
username dialup password 7 XXXXX
username traffic password 7 XXXXX
cable modem remote-query 30 test
cable modem max-cpe 5
cable spectrum-group 1 frequency 24000000 12
cable modulation-profile 2 request 0 16 0 8 16qam scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 2 initial 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 2 station 5 34 0 48 16qam scrambler 152 no-diff 256 fixed uw16
cable modulation-profile 2 short 6 75 6 8 16qam scrambler 152 no-diff 144 fixed uw8
cable modulation-profile 2 long 8 220 0 8 16qam scrambler 152 no-diff 160 fixed uw8
cable modulation-profile 3 request 0 16 0 8 qpsk scrambler 152 no-diff 64 fixed uw16
cable modulation-profile 3 initial 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 station 5 34 0 48 qpsk scrambler 152 no-diff 128 fixed uw16
cable modulation-profile 3 short 7 76 7 8 16qam scrambler 152 no-diff 144 shortened uw16
cable modulation-profile 3 long 9 220 0 8 16qam scrambler 152 no-diff 160 shortened uw16
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
aaa new-model
!
!
aaa authentication login ssh local
aaa authentication login AUX local
aaa authentication login CONSOLE local
aaa authentication ppp cisco-radius group radius
aaa authentication ppp ppp_aux local
aaa authorization network cisco-radius group radius
aaa accounting delay-start
aaa accounting update newinfo
aaa accounting network cisco-radius start-stop group radius
aaa session-id common
ip subnet-zero
no ip source-route
ip rcmd rsh-enable
ip rcmd remote-host traffic 172.18.1.202 root enable
ip rcmd source-interface FastEthernet0/0
ip flow-cache entries 10000
ip flow-cache feature-accelerate
!
!
ip cef
ip domain name tkt1.zvezda
ip host traffic 172.18.1.202
ip name-server 172.18.1.202
ip dhcp ping packets 1
!
ip ssh authentication-retries 2
ip dhcp-server 172.18.1.202
ip accounting-threshold 1000
vpdn enable
!
vpdn-group 1
accept-dialin
protocol pppoe
virtual-template 1
!
no mpls ldp logging neighbor-changes
!
!
!
modemcap entry whatever:MSC=&fs0=2
!
!
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
ip address 172.18.1.12 255.255.255.0
ip access-group 101 in
ip directed-broadcast
ip route-cache flow
no ip mroute-cache
duplex full
speed 100
no cdp enable
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
ip directed-broadcast
ip route-cache flow
shutdown
duplex auto
speed auto
no cdp enable
!
interface Cable1/0
description power level for RF signal 45-63 dbmv
ip address 10.254.1.1 255.255.255.0 secondary
ip address 10.128.0.1 255.255.0.0
ip access-group 102 in
ip accounting output-packets
cable spectrum-group 1
cable downstream annex A
cable downstream modulation 256qam
cable downstream frequency 410000000
cable downstream channel-id 0
no cable downstream rf-shutdown
cable downstream rf-power 50
cable upstream 0 frequency 23600000
cable upstream 0 power-level 12
cable upstream 0 channel-width 3200000
cable upstream 0 minislot-size 4
cable upstream 0 modulation-profile 2
no cable upstream 0 s160-atp-workaround
no cable upstream 0 shutdown
cable upstream 1 channel-width 1600000
cable upstream 1 minislot-size 4
cable upstream 1 modulation-profile 1
no cable upstream 1 s160-atp-workaround
cable upstream 1 shutdown
cable upstream 2 channel-width 1600000
cable upstream 2 minislot-size 4
cable upstream 2 modulation-profile 1
no cable upstream 2 s160-atp-workaround
cable upstream 2 shutdown
cable upstream 3 channel-width 1600000
cable upstream 3 minislot-size 4
cable upstream 3 modulation-profile 1
no cable upstream 3 s160-atp-workaround
cable upstream 3 shutdown
cable source-verify dhcp
cable dhcp-giaddr policy
cable helper-address 172.18.1.202
cable privacy 40-bit-des
pppoe enable
no keepalive
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
ip mtu 1492
autodetect encapsulation ppp
peer default ip address pool pppoe_pool
ppp authentication pap chap cisco-radius
ppp authorization cisco-radius
ppp accounting cisco-radius
ppp timeout authentication 20
ppp timeout idle 3600
!
interface Async1
ip unnumbered FastEthernet0/0
encapsulation ppp
ip tcp header-compression
no ip mroute-cache
autodetect encapsulation ppp
async default routing
async mode interactive
peer default ip address pool dialup
no keepalive
ppp authentication pap ppp_aux
!
ip local pool dialup 172.18.1.203 172.18.1.204
ip local pool pppoe_pool 172.18.1.205 172.18.1.206
ip classless
no ip forward-protocol udp netbios-ns
ip route 0.0.0.0 0.0.0.0 172.18.1.1
ip flow-export source FastEthernet0/0
ip flow-export version 5
ip flow-export destination 172.18.1.202 9996
ip flow-aggregation cache destination-prefix
cache entries 2046
export destination 172.18.1.202 9996
!
no ip http server
no ip http secure-server
!
!
!
logging trap debugging
logging facility local4
logging 172.18.1.202
access-list 101 permit ip any any
access-list 102 permit udp 10.254.1.0 0.0.0.255 any eq domain
access-list 102 permit udp any any eq bootps
access-list 102 permit udp 10.128.0.0 0.0.255.255 host 172.18.1.202 eq tftp
access-list 102 permit udp 10.128.0.0 0.0.255.255 host 10.128.0.1 eq time
access-list 102 permit tcp 10.254.1.0 0.0.0.255 host 172.18.1.1 gt 1024
access-list 102 permit tcp host 10.254.1.7 any
access-list 102 permit udp host 10.254.1.7 any
access-list 102 permit udp any host 172.18.1.202
access-list 102 permit udp any host 172.18.1.201
access-list 102 permit icmp 10.254.1.0 0.0.0.255 10.254.1.0 0.0.0.255
access-list 102 permit icmp 10.254.1.0 0.0.0.255 10.128.0.0 0.0.255.255
access-list 102 permit udp 10.128.0.0 0.0.255.255 host 10.254.1.7
access-list 102 deny tcp 10.254.1.0 0.0.0.255 host 172.18.1.1 lt 1024
access-list 102 deny tcp 10.254.1.0 0.0.0.255 172.18.1.0 0.0.0.255
access-list 102 permit tcp 10.254.1.0 0.0.0.255 any
no cdp run
!
snmp-server community public RO
snmp-server community test RO
snmp-server enable traps tty
snmp-server manager
radius-server attribute nas-port format d
radius-server host 172.18.1.202 auth-port 1812 acct-port 1813
radius-server timeout 10
radius-server key 7 XXXX
radius-server authorization permit missing Service-Type
alias exec scm show cable modem
privilege exec level 8 show ip accounting checkpoint
privilege exec level 8 show ip accounting
privilege exec level 8 show ip
privilege exec level 8 show
privilege exec level 8 clear ip accounting checkpoint
privilege exec level 8 clear ip accounting
privilege exec level 8 clear ip
privilege exec level 15 clear cable modem
privilege exec level 15 clear cable
privilege exec level 15 clear
!
line con 0
login authentication CONSOLE
line aux 0
password 7 105A0C0A11
login authentication line
modem InOut
modem autoconfigure type whatever
autocommand ppp
terminal-type vt100
transport preferred none
transport input all
stopbits 1
speed 38400
flowcontrol hardware
line vty 0 4
exec-timeout 0 0
login authentication ssh
line vty 5 15
!
scheduler allocate 3998 400
ntp clock-period 17180050
ntp server XXXXX
end




Модемный скрипт под Windows'98, Windows2000, для работы с AUX портом на Cisco:

proc main
delay 2
waitfor "rname:",matchcase until 60
delay 1
;transmit $USERID
transmit "admin"
transmit "^M"
waitfor "assword:",matchcase until 60
delay 1
;transmit $PASSWORD
transmit "XXXXXXX"
transmit "^M"
delay 1
transmit "ppp"
transmit "^M"
;waitfor "PPP",matchcase until 30
delay 1
endproc


!Кусок конфига для MRTG - уровень сигнал/шум для обратного канала,
!загрузка процессора, ошибки на интерфейсе.
! Первые две строки пишутся в одну строчку.
Target[router_snr-cable-1-u0]:1.3.6.1.2.1.10.127.1.1.4.1.5.4&1.3.6.1.2.1.
10.127.1.1.4.1.5.4:public@172.18.1.12 / 10
Options[router_snr-cable-1-u0]: gauge, noinfo, absolute
#Directory[router_snr-cable-1-u0]: router
MaxBytes[router_snr-cable-1-u0]: 45
Ylegend[router_snr-cable-1-u0]: SNR
ShortLegend[router_snr-cable-1-u0]:
Legend1[router_snr-cable-1-u0]:
Legend2[router_snr-cable-1-u0]:
Legend3[router_snr-cable-1-u0]:
Legend4[router_snr-cable-1-u0]:
LegendI[router_snr-cable-1-u0]: snr
LegendO[router_snr-cable-1-u0]:
Title[router_snr-cable-1-u0]: SNR for Cable1/0 Upstream 0
PageTop[router_snr-cable-1-u0]:<H1>SNR for Cable1/0 Upstream 0</H1>
!
!
Target[uBR7114]:1.3.6.1.4.1.9.2.1.58.0&1.3.6.1.4.1.9.2.1.58.0:public@
172.18.1.12
RouterUptime[uBR7114]: public@172.18.1.12
MaxBytes[uBR7114]: 20
Title[uBR7114]: CPU LOAD
PageTop[uBR7114]: <H1>7114 CPU Load 5 min averages</H1>
Unscaled[uBR7114]: ymwd
ShortLegend[uBR7114]: %
YLegend[uBR7114]: CPU Utilization
Legend1[uBR7114]: CPU Utilization in % (Load)
Legend2[uBR7114]: CPU Utilization in % (Load)
Legend3[uBR7114]:
Legend4[uBR7114]:
LegendI[uBR7114]:
LegendO[uBR7114]: Usage
Options[uBR7114]: gauge,growright
!
!
Target[7114_er]:1.3.6.1.2.1.2.2.1.14.4&1.3.6.1.2.1.2.2.1.14.4:public@
172.18.1.12
MaxBytes[7114_er]: 100
#XSize[uBR7114_er]: 300
#YSize[uBR7114_er]: 200
YLegend[7114_er]: errors/min
Title[7114_er]: packet error
Options[7114_er]: growright,perminute
PageTop[7114_er]: <H1>packet error</H1>


Дублирование и синхронизация дисков для обеспечения избыточности и надежности системы -
что-то типа дешевого рейда. В этом решении есть свои преимущества - всегда можно
вернуться к прежней конфигурации (например из-за ошибки админа)т.к. синхронизация
осуществляется один раз в сутки. Таким же образом можно делать холодные копии баз
данных в том числе и на другой хост через ssh.

#!/bin/sh
/usr/bin/rsync -aH --delete /tmp/ /mnt/other/sdb6
/usr/bin/rsync -aH --delete /usr/ /mnt/other/sdb5
/usr/bin/rsync -aH --delete /var/ /mnt/other/sdb2
/usr/bin/rsync -aH --delete /home/ /mnt/other/sdb7
/usr/bin/rsync -aH --delete /boot/ /mnt/other/sdb1
/usr/bin/rsync -aHD --delete --exclude-from=/root/BACKUP/exclude.txt /* /mnt/other/sdb3

exclude.txt:
/mnt/other/*.* /var/*.* /usr/*.* /tmp/*.* /home/*.* /boot/*.* /proc/*.*





PS На все это "безобразие" можно посмотреть здесь.

Ссылки для админа провайдерского узла по телевизионным кабельным сетям
(и не только):

1. Docsis_server - свободная система обеспечения кабельных модемов
 стандарта  DOCSIS. Включает DHCP, TFTP, TOD, SYSLOG сервисы. Данные
 хранятся в MySQL базе. Эту же систему уже за деньги 7500$ продают
 здесь. :) Можно использовать отдельные сервисы, например, DHCP, если
 необходимо хранение информации в СУБД (а без этого биллинговой
 системы для кабельных провайдеров не построить). Тестировалась
 последняя версия - 1.2.0
http://users.accesscomm.ca/docsis_server/
http://freshmeat.net/projects/docsis_server/

2. FreeRadius сервер. Есть поддержка MySQL, Oracle. Версия 0.9.3.
http://www.freeradius.org/

3. freenibs-0.0.3-release2 для FreeRadius 0.9.3 - модуль для FreeRadius'а
с www итерфейсом, позволяющий получить полноценную биллинговую систему.
http://nibs.is.kh.ua/src.html
http://freenibs.org/src/

4. docsis - утилита для генерации на основе текстовых конфигов бинарных
 файлов конфигурации для кабельных модемов. Есть и для Linux и
для Windows. Версия 0.9.0.
http://sourceforge.net/projects/docsis/

5. Flowc - иструмент для сбора и анализа трафика посредством NetFLow v5.
MySQL как backend. Имеет www интерфейс на PHP. Версия 1.5beta.
http://netacad.kiev.ua/flowc/
http://sourceforge.net/projects/flowc/

6. NetAms - система учета и анализа трафика. Поддержка NetFlow
 (и не только) и MySQL.
http://www.netams.com/

7. MRTG - анализ трафика (и не только ) на сетевых интерфесах в виде
 красивых графиков, доступных через браузер. (MRTG 2.10.13)
http://people.ee.ethz.ch/~oetiker/webtools/mrtg/

8. raspppoe клиент для windows реализующий протокол PPPoE.
http://www.raspppoe.com/

9. dhcp, bind - сервера DHCP и DNS.
http://www.isc.org/

10. Быстрый и маленький www сервер.
http://www.acme.com/software/thttpd/

11. Uptime для сайта.
http://uptime.netcraft.com/up/

12. Zebedee - криптованный тунель
http://www.winton.org.uk/zebedee/

13. NOC Relcom
http://noc.relcom.net

14. JpGraph - OO Graph Library for PHP
http://www.aditus.nu/jpgraph

15. Скорость канала.
http://www.info-techs.com/speedtest50.html

16. Система Multi Admin Billing System
(сокращенно MABill) является биллинговой
системой для интернет-провайдеров.
http://www.mabill.ru

17. Выбери себе IOS
http://tools.cisco.com/ITDIT/ISTMAIN/jsp/index.jsp?calling_app=config

18. Docsis CPE configurator - средство создания
конфигурационных файлов для кабельных модемов. 
http://www.cisco.com/support/toolkit/CableModem

19. RIPN
http://www.ripn.net:8080/nic/whois

20. Разный софт для работы с NetFlow.
http://www.switch.ch/tf-tant/floma/software.html

21. Frontend для администрирования MySQL.
http://www.phpmyadmin.net/home_page

22. LibPNG.
http://www.libpng.org

23. library for JPEG image compression.
http://www.ijg.org

24. GD lib. (gd-1.8.4)
http://www.boutell.com/gd

25. NetSNMP (Версия net-snmp-5.1)
http://www.net-snmp.org

26. Updates Trustix 2.0
ftp://ftp.trustix.org/pub/trustix/updates/2.0/rpms

27. Лучшая программа для UPS APC
http://www.apcupsd.com

28. Монтирование удаленных файловых систем по SSH. Давно ждал!
http://shfs.sourceforge.net/

29. Тонкий клиент. Windows Terminal Services,
Citrix ICA, X-terminal, TightVNC, SSH, Telnet, Tarantella
http://thinstation.sourceforge.net/index.html

30. Интернет телефония. Супер!
http://ui.skype.com/skype.html



WWW

1. Известный форум UBBThreads
http://www.infopop.com/products/ubbthreads

2. Еще один форум на PHP
http://myphpbb.com.ru